Haberler

CVE-2019-0211 - Apache Yetkisiz Kod Çalıştırma Açığı
Wednesday, April 3, 2019

Merhabalar,

1 Nisan 2019 itibarı ile Apache web servisi üzerinde, sunucuda yetkisiz olarak script çalıştırılabilmesini sağlayan bir açık tespit edilmiştir.

CVE-2019-0211 kodlu olan açık, Apache altında çalışan ve daha az yetkileri bulunan alt işlem ve istemciler üzerinden çalıştırılan zararlı kod ile Apache'nin yetkisini ele geçirmek (ki Apache web servisi sunucularda genelde root kullanıcısının altında çalıştığı için root yetkilerini ele geçirmek) ve bu yetkiler ile script çalıştırabilmeyi mümkün kılmak üzerinedir.

Bu lokal bir açıktır, Yani açığı kullanmak isteyen kişinin sunucuya erişimi olması gerekmektedir. (Paylaşımlı bir hosting sunucusundan hizmet alması yeterlidir)

Apache 2.4.17 sürümünden beri var olan açık 2.4.38 sürümünde de mevcuttur.

İlgili problem, Apache'nin 2.4.39 sürümünde giderilmiştir.

Firmamız bünyesinde Linux işletim sistemi kullanan Sunucularda sağlanabilen bütün kontrol panelleri, Apache web servisi ile birlikte geldiği için aksiyon almanız önemlidir.

Panelinize göre aşağıdaki dökümanlar üzerinden güncelleme gerçekleştirebilirsiniz;

DirectAdmin için: https://help.directadmin.com/item.php?id=1
cPanel için; https://documentation.cpanel.net/display/CKB/How+to+Update+Your+System#HowtoUpdateYourSystem-UpdateApache
Plesk: Plesk panel, kendi reposu üzerinden kurulum gerçekleştirmediği ve OS reposunu (Örneğin CentOS Repo) kullandığı için SSH üzerinden güncelleyebilirsiniz.

Servis Seviyesi 3 ve Servis Seviyesi 4 hizmetine sahip olan müşterilerimiz, Güncellemeyi tarafımızdan bir E-Destek bildirimi oluşturarak talep edebilirler.

Kaynak: https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2019-0211

İyi çalışmalar dileriz

<< Önceki Sayfa